View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Header

The Header contains various menus, navigation elements, settings and tools for the viewport.

17
 min read
Up to date for 
5.1
draft

Shader Editor - Header

The Header contains various menus, navigation elements, settings and tools for the viewport. This content differs, dependent of the sub mode. And the content of the menus may differ too, dependent of the chosen renderer.

The header is divided into two areas. Left mode and menus. Right settings.

Shader Editor - Header
Shader Editor - Header

Header Tabs

Header Tabs

The tabs at the very left allows you to switch between the most important node editor types by one click. Compositor Editor, Geometry Nodes Editor and Shader Editor.

Header right click menus

The general right click menu functionality is explained in chapter 6 Editors introduction.

Editortype Menu

Editortype Menu

Bforartists is made of several editor types. Headers can display a menu where you can switch to other editor types.

This menu is hidden by default. It is meant to edit the layouts, and should not be necessary for regular work. You can reveal it in the header right click menu.

Editortype Menu

Sub Modes

Sub Modes

The Shader Editor has three shader type sub modes. Every sub mode has some different set of shaders for its own purpose.

EntryWhat it does
ObjectThe Object mode is for the scene objects. It shows materials and shader for the scene objects.
WorldIn the World mode you can change the shaders and materials for the world settings. It shows the world shaders and materials.
Line StyleThe Line Style mode allows you to set up materials for the Freestyle renderer. Freestyle rendering must be active for this. It shows the Freestyle materials and shaders.

Tools and Options

Introduction

The header in the Shader editor contains various menus and tools. This chapter here is about the tools, modes and options elements in the header.

The text menus are covered in a own chapter each. They vary too much, dependent of mode and object type.

Shader Type Drop-down Box

Shader Type Drop-down Box
Shader Type Drop-down Box

The Mode drop-down box allows you to switch between the different shader type modes. An object has a different set of available shaders than the world or a line style shading.

EntryWhat it does
ObjectIn this mode you work with the scene objects and its materials.
WorldIn this mode you work with the world settings. HDRI's for example.
Line StyleIn this mode you work with Freestyle renderer materials.

Object Context menu

Object Context menu

When you right click at the dropdown box then you will reveal the Object context menu.

Slot

Slot

This element just exists in Object mode.

The Slot menu displays the assigned material(s) at the current active mesh. It can be used to select the active material on the active object. And to select or assign materials to different mesh parts of the same object.

When you add a material by clicking at the new button in the material prop, or by choosing another material from the materials browser, then it is usually also added or changed in the slot system in the current position.

Slot
EntryWhat it does
List of materialsThe list of materials in the slot list.
Add Material SlotAdds a new material slot. When you do this manually then this slot will be empty.
Remove Material SlotRemove the selected material slot. The removed material will not longer be part of the currently active mesh.

Copy and Paste menu

Copy and Paste menu
Copy and Paste menu

Copy and paste materials. But just at the current active mesh. Means in Edit Mode.

EntryWhat it does
Copy MaterialCopies the currently selected material
Copy Material to SelectedCopies the currently selected material, and pastes it to the selection
Paste MaterialPastes the material.
Remove unused SlotsClean up unused slots.
EntryWhat it does
Move Material Up / DownMoves the selected material up or down in the list.
AssignThis button appears when you are in Edit mode in the 3D view. Assign the selected material to the selected geometry.
SelectThis button appears when you are in Edit mode in the 3D view. Select the geometry where this material is assigned to.
DeselectThis button appears when you are in Edit mode in the 3D view. Deselects the geometry where this material is assigned to.

Search Field

Search Field

When you click at the little triangle button below the list then you can reveal a search element. The buttons should be self explaining. So we won't go into detail here.

Material Prop

Material Prop

Create a new material, and see a list of the available materials in the scene.

Material Browser

Material Browser

The list of available materials in the scene.

New

Creates a new material.

Material edit box

The name of the current active material. Here you can also rename the material.

Material edit box
Material edit box
Material edit box

Note that the name and available materials differs, dependent in which mode you are. In Object mode you will see the object materials. In World mode the world materials. And in Line Style mode the materials for Freestyle rendering.

EntryWhat it does
Fake UserWit this button you assign a fake user to this selected image. Data, like images, that is not longer linked to anything else gets removed when you save and reload a scene. Bforartists has the concept of fake users to go around this behavior. An image with a fake user is in fact linked to something. And so it is not lost when you save and reload the scene.
Clear AssetWhen you have marked the material as asset, then the fake user button is replaced by a Clear Asset button. It allows you to clear the asset.
NewCreates a new material.
RemoveRemoves the material. To delete it completely you need to purge it. See Fake user.

Right Click menus

When you right click at the material property then you will reveal context menus with different content, dependant of where you click. Most of the content is explained in chapter 6, the general right click menu functionality. The rest should be self explaining.

Right Click menus
Right Click menus
Right Click menus
Right Click menus

Options

Options

At the right side you will see some options.

Use Nodes

Use Nodes

The Use Nodes setting is mostly a legacy setting. And displays just in Line Style mode.

EntryWhat it does
Pin (pin icon)The pin button will keep the current material selection fixed. When a material is pinned, it will remain visible in the shader editor even when another object or material is selected elsewhere.
SnapActivates snapping.

Node Editor Overlays

Node Editor Overlays

Activates the node editor overlays. When the tool is activated, then you will also overlays settings in the editor. The drop down arrow to the right shows different overlay types.

Show Overlays

Show or hide the overlays.

Wire Colors

Wire Colors

Color node links based on their connected sockets.

Example: The color RGB socket is yellow that makes a yellow line, and the Shader BSDF socket is green that makes a green line.

Reroute Auto Labels

Reroute Auto Labels

Label reroute nodes based on the label of connected reroute nodes.

Example: The first reroute label to the right has concurring reroute labels down the line. If you toggle this off, the concurring reroute labels down the line won’t contain labels.

Context Path

Context Path

Display breadcrumbs for the editor’s context.

Annotations

Shows annotations for this editor view that have been drawn by the annotation tool.

Quick Menu

Quick Menu

Quick Menu

The quick menu, or in long Quick Favorites menu, is a menu that can be customized to your needs. Here you can add operators for quick access.

It is located in the header. But it can be called by hotkey Q directly under the mouse. This hotkey works in other editors too.

When the menu is empty, then you will see the message "No Menu Items found". This means that you first have to add some tools to the menu. It is a user configurable menu.

Note that added operators in this menu does not have icons. Just text.

Adding an operator to the Quick menu

Adding an operator to the Quick menu
Adding an operator to the Quick menu

Open the panel or the menu where your operator is that you want to add.

Let's add the open command from the File menu. Open the File menu, right click at open, and choose Add to Quick Favorites.

Do the same with Save As. We should now have two new menu items in the Quick menu, which you can use now.

Adding an operator to the Quick menu
Adding an operator to the Quick menu

As a rule of thumb, when the right click menu has an Add to Quick Favorites, then you can add it to the quick menu.

Note that you can also add operators from the tool shelf at the left. And also operators from other editor types. Some other editors have their own quick menu though. The Image Editor for example. These operators gets added in the quick menu of the image editor then. And does not show in the quick menu in the header of the 3D view.

Adding a menu to the Quick menu

Adding a menu to the Quick menu
Adding a menu to the Quick menu

It is also possible to add a menu to the Quick menu. For example the whole Add menu. The way is the same. Right click at it, and choose Add to Quick Favorites.

Adding a menu to the Quick menu
Adding a menu to the Quick menu

Order

You might notice that the add menu adds at the top of the menu, and not at the bottom as you would expect. First comes menus, then comes operators. And they get added in the order in which you add them.

Besides that, operators and menus gets added in the order that you add them. They cannot be sorted afterwards. So be careful how you add them. You can of course always remove operators and menus, and re-add them at the end of the list.

Removing an operator from the Quick menu

The Quick Favorites menu (Q) holds the tools and menus you add to it yourself. See Quick Favorites in the Interface chapter.

Context and mode dependent content

The quick favorites. menu exists in nearly all editors. But it is just in the 3D view available in the header. So that you know this functionality exists. In the other editors you call it with hotkey Q.

The content of the quick favorites. menu changes, dependent over which editor you are, and in what mode you are. When you add for example an operator from the image editor, then this operator just shows in the quick menu when you call the menu from the image editor. Same goes for the modes. Edit mode tools will just show in edit mode. And so on.

View Menu

View Menu

View Menu

The View menu contains all View related tools.

The content is the same in all sub modes.

Toolbar

Toolbar

Shows or hides the toolbar at the left.

Sidebar

Shows or hides the sidebar at the right in the Shader Editor.

Asset Shelf

Shows or hides the Asset Shelf to the bottom of the Shader Editor.

Asset Shelf

Annotations (Legacy)

Annotations (Legacy)

This group of operators is useful to take notes without changing tool-shelf operators. These notes can be colored in the View tab of the Property Shelf. Each layer is a single color. You can also animate the notes with keyframes, editable in the dopesheet.

Note: These are legacy operators, meaning they are equally available in the Toolshelf as a modal operator.

EntryWhat it does
Draw AnnotationStarts the annotation free hand draw tool in the editor.
Draw Line AnnotationStarts the annotation line draw tool to draw straight lines in the editor.
Draw Polyline AnnotationStarts the annotation Polyline draw tool in the editor which allows to draw multiple connected straight lines in the editor.
Erase AnnotationStarts the annotation erase tool in the editor which erases any strokes in the editor.
Add Annotation LayerStarts a new annotation layer.
Erase Annotation Active KeyframeErases the active keyframe of the annotation.
EntryWhat it does
Link to OutputCreates a temporary connection to the Output Node, allowing to quickly preview the output of any node within the shader editor by clicking on it. Note: This operator only works under the mouse cursor and is shown in this menu for discoverability purposes only.
Zoom InZooms into the viewport.
Zoom OutZooms out of the viewport.
Zoom BorderDraws a rectangle and zooms then to fit the size of this rectangle. Zooming in is done with drawing the rectangle with left mouse button. Zooming out is done with drawing the rectangle with middle mouse button.
Frame SelectedZooms to the selection.
Frame AllView all zooms in or out in the viewport until all objects in the scene are displayed fitting in the viewport.

Pie menus

Pie menus

Lists the available pie menus, and gives you the ability to read the hotkeys and assign own hotkeys.

Area

Area

This menu contains general view functionality. And exists in most other editor types too.

Horizontal Split

Splits the current view horizontally into two independent editor windows.

Vertical Split

Vertical Split

Splits the current view vertically into two independent editor windows.

EntryWhat it does
Duplicate Area into New WindowDuplicate Area into New Window makes the selected editor window floating. You can then drag it around at the monitor. It is not connected with the rest of the UI anymore. A separated window cannot be merged into the main window again. You have to close it when not longer needed.
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaCloses the editor.

Select Menu

Select menu

Select menu

Here you will find the select functionality.

Legacy

Legacy

The legacy sub menu contains tools that exists in the tool shelf already. It's the old way to do things. Different to the tools in the tool shelf, these tools are usually modal. And performs once. You have to call them again in case you want to repeat the tool.

EntryWhat it does
Box selectDraw a rectangle to select everything inside of the rectangle. It automatically adds to the current selection. Holding down shift subtracts from the selection.
Circle selectBrush select content. The radius of the brush can be adjusted by holding down left mouse button and using the scroll wheel or the + or - button at the numpad. It automatically adds to the current selection. Holding down shift subtracts from the selection. To exit the circle select tool click with the right mouse button.

Lasso Select

Lasso Select

A sub menu with the available lasso select modes.

EntryWhat it does
AllSelect everything.
NoneSelect nothing.
InverseInvert the current selection.
Linked FromSelect the nodes that are linked from the currently selected nodes. The nodes before in the hierarchy.
Linked ToSelect the nodes that are linked to the currently selected nodes. The nodes behind in the hierarchy.
GroupedSelect grouped nodes.
Grouped ExtendSelect grouped nodes, and extend from the current selection.
Activate same type previousActivate same node type before the current selection, step by step.
Activate same type nextActivate same node type after the current selection, step by step.

Find Node

Find Node

This button will open a search dialog where you can search for node types and select them in the current hierarchy.

Swap Menu

Swap

Replace the selected node by another node from the swap menu.

Swap

Node Menu

Node menu

Node menu

This menu contains further node functionality.

Move

Moves the selected nodes.

Rotate

You can't rotate single nodes, obviously. But when you have more than one selected then you can rotate them around their center point.

Resize

You can't resize single nodes, obviously. But when you have more than one selected then you can scale them around their center point.

Cut

Copies the selected nodes to the clipboard and removes them, keeping the links around them connected. Paste them back with Paste. Hotkey Ctrl + X, like in most programs.

Copy

Copies the selected node(s) to the clipboard, for reuse with the paste operator in the current or other instances of Bforartists that are open.

Paste

Pastes the selected node(s) from the above mention copy operator that are in the clipboard, in the current session of Bforartists or another instance that are open.

Duplicate Keep Input

This works at nodes that have a connected input. Duplicating will keep the input connections established in the duplicated node. The output connections will be removed.

Duplicate

Duplicates the selected node(s). All connections will be removed in the duplicated node.

Duplicate Linked

Duplicates the selected node(s). But not their node trees. And move them.

Delete

Deletes the selected node(s).

Delete with Reconnect

Deletes the selected node(s). When this node is in the middle of a connection, then the connections will be reconnected.

Join in new Frame

Frame node functionality. Adds the selected node to a frame.

Remove from Frame

Frame node functionality. Removes the selected node from a frame.

Join Group Inputs

Merge selected group input nodes into one if possible.

Join in Named Frames

Create a new frame node, and name it immediately.

Frame Make Parent

Frame node functionality. Adds the selected node to a frame.

Rename

Rename the selected node.

Group submenu

Group submenu

Make Group

Groups the selected nodes together.

Select the nodes that you want to group together. Choose Make Group. You will now see a green background. This indicates that the group is created, and that you are in edit mode for the group now.

Make Group
Make Group

To exit the group edit mode press Tab key, or choose Toggle Edit Group menu item in the sidebar in the Relations tab in the Group panel. That way you can also enter the Group Edit mode again.

Make Group
Make Group
Make Group

There is a third way to enter the group edit mode. Click at the right upper icon of the group node.

Make Group

A group can be further collapsed by clicking at the triangle button in the upper left corner.

Make Group

The group can be renamed in the sidebar in the Item tab and in the Properties tab in the Node panel.

EntryWhat it does
Insert into GroupAllows you to insert a node into a node group. Select the node, hold down Shift, then select the node group so that both are selected. Then perform the operator.
UngroupUngroups an existing group. You need to be outside of the group edit mode.
Toggle Edit GroupEnters a node group for editing. Or when you are in a node group, exits the node group editing.
Links submenu
EntryWhat it does
Make LinksTries to connect nodes where it makes sense. For example, the BSDF output of a Principled shader with the Surface input of the Material Output node.
Make and Replace LinksSame as Make Links. But it will replace existing links.
Cut LinksCut the links under the mouse.
Detach LinksRemoves all connections from the selected node, but tries to reconnect the remaining nodes.
Detach Links MoveRemoves all connections from the selected node by dragging.
Mute LinksMute the links under the mouse.

Separate submenu

Separate submenu

Node group functionality. You need to be in edit group mode.

EntryWhat it does
CopyCopies the selected node, and pastes a copy of it outside of the node group. The node group remains unchanged.
MoveMoves the selected to outside of the node group, and removes it from the node group.

Show/Hide submenu

Show/Hide submenu

Here you find hide options to make the display of nodes more compact.

Show/Hide submenu

Demonstration happens at an image node.

Collapse

Collapse

Hides everything but input and output dots. To view the full node again perform the operator again. It's a toggle. Or click at the triangle left besides the node name.

Toggle Node Mute

Deactivates the node.

Toggle hidden node sockets

Toggle hidden node sockets
Toggle hidden node sockets

Toggles away the unused node sockets. In this case the vector input node socket and the alpha output node socket will be hidden.

Toggle Node Options

Toggle Node Options

Hides away the properties.

Collapse and Hide Unused Sockets

Collapse and Hide Unused Sockets
Collapse and Hide Unused Sockets

Like Hide. Hides everything but the node sockets. But it also hides the unused node sockets.

In this chapter

  • Add Menu — Every node you can add, by category: open a category for its nodes.