View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Sidebar

The Movie Clip Editor is made of several areas.

13
 min read
Up to date for 
5.1
draft

Introduction

Introduction

The Movie Clip Editor is made of several areas. And it is made of several modes with different editor types.

At the right side you will find the sidebar in Tracking Mode with Clip view. And in Masking mode. In the sidebar you will find further options and settings for the Movie Clip Editor and its tools.

Right Click menus

Right Click menus

You will open the usual right click menus when clicking with the right mouse at elements in the sidebar. Its content is in big parts self explaining.

The right click menus are explained in the chapter 6 Editors Introduction.

Footage Tab

Preface

Note that the correct mode is Tracking Mode in Clip View. In Graph and Dopesheet View there is no sidebar.

Note also that some panels exists in both modes, tracking and masking. They have sometimes different content though.

Footage Tab - Metadata Panel

Footage Tab - Metadata Panel
Footage Tab - Metadata Panel

Displays the metadata of the footage if available. The panel stays empty if there is none.

Footage Tab - Proxy/Time code Panel

Footage Tab - Proxy/Time code Panel
Footage Tab - Proxy/Time code Panel

This content shows in Tracking Mode and Masking mode.

A proxy is a smaller replacement image for the main image. Think of it as a thumbnail. The creation may take some time. But once done, all other calculations happens much faster. So it can make sense to use proxies for bigger footage.

Make sure to disable the Proxy images before doing the final render!

EntryWhat it does
Use Proxy / TimecodeUse Proxy / Timecode for this clip.
Build OriginalDefine the resolution of the proxy images.
Build UndistortedBuilds the proxy images from the undistorted original images for the sizes set above.
QualityDefines the quality of the JPEG images used for proxies.

Proxy Custom Directory

Proxy Custom Directory

By default, all generated proxy images are storing to the <path of original footage>/BL_proxy/<clip name> folder. Define a custom directory.

EntryWhat it does
Build Proxy / Time code(Re)creates the proxy images and the time code.
Delete ProxyDeletes the proxy images and the time code.

Time code Index

Time code Index

When you are working with footage directly copied from a camera without pre-processing it, then there might be a bunch of artifacts. In this case the calculation can give errant result. One way to avoid this is to use the Proxy / Time code option. Another method would be to use a external tool like Mencoder to repair the file header and insert correct keyframes.

Note: Record Run is recommended for most needs. Buf when the clip’s file is totally damaged, Record Run No Gaps will be the only chance of getting acceptable result.

Proxy Size

Proxy Size

This setting defines which proxy image resolution is used for display in the viewport. If there is no generated proxies, render size is set to “No proxy, full render”.

Footage Tab - Footage Settings Panel

Footage Tab - Footage Settings Panel
Footage Tab - Footage Settings Panel

This content shows in Tracking Mode and Masking mode.

The panel contains some footage related settings.

EntryWhat it does
File PathThe file path for the currently loaded and active video. Here you can also load another video, or refresh the video.
Start FrameThe start frame for the currently loaded and active video.
Frame OffsetDefine a frame offset.

Color Space

Color Space

The color space for the currently loaded and active video.

Footage Information string

Here you will find some information about the footage. Size, color mode, fps, current position ...

Footage Tab - Animation Panel

Footage Tab - Animation Panel
Footage Tab - Animation Panel

Load am action clip with animation. You need to generate it first.

Track Tab

Preface

Note that the correct mode is Tracking Mode in Clip View. In Graph and Dopesheet View there is no sidebar.

Note also that most panels just shows in tracking mode, and not in masking mode.

Track Tab - Track Panel

Track Tab - Track Panel
Track Tab - Track Panel

Marker settings for the currently selected marker.

Edit Box

Read and edit the name of the currently selected marker.

EntryWhat it does
EnableEnable the currently selected marker.
LockLock the currently selected marker.

Track Scope

Track Scope

This is a preview image and fine tune window for the currently selected marker. The fade cross stays always in the center, but you can move the image with the left mouse. This automatically records the changed position, and inserts a keyframe at the current position if necessary.

You can pull it vertically bigger by pulling at the handler below the image. And horizontally bigger by pulling out the properties sidebar.

If an anchor is used (the position in the image which is tracking is different from the position which is used for parenting), a preview widget will display the area around the anchor position.

Color Settings

R, G, B

R, G, B

Use red, green and blue color in the preview image.

EntryWhat it does
B/WUse a greyscale preview image.
AlphaUse existing alpha channel for preview image.
EntryWhat it does
WeightThe influence of this track to the final solution. Altering the weights of problem tracking markers can correct or greatly reduce undesirable jumps. This parameter can be animated.
Stab WeightStabilization weight. The influence of this track on 2D stabilization.
Average ErrorThe average error of this marker.

Custom Color

Custom Color

Give the markers different colors. This also affects the list of markers in Dope sheet view.

Custom Color
Custom Color

Color Preset

Color Preset

A dropdown box to choose between some predefined colors.

Copy Color

Copy the color of the currently chosen preset.

Color

Color

When you tick custom color then a color field will appear below. It displays the current custom color, and allows you to change the color by clicking at it. A color picker will appear.

Track tab - Objects Panel

Track tab - Objects Panel
Track tab - Objects Panel

This content shows in Tracking Mode and Masking mode.

A list of the tracked objects. Usually the camera. But you can track every other object too.

Add, Remove Tracking Object

The plus and minus buttons at the right allows you to add new objects to the list, or to remove existing objects from the list.

Search Field

Search Field

The list field contains a hidden search field. Click at the little + button down left to reveal it.

Track tab - Plane Track Panel

Track tab - Plane Track Panel
Track tab - Plane Track Panel

This content is just active and visible when you have a Plane track in your footage.

See also in the Tool shelf in the Solve tab in the Plane Track panel.

EntryWhat it does
NameThe name of the Plane track.
Auto KeyframeUse Auto Keyframe when moving plane track corners.

Image prop

Image prop
EntryWhat it does
Image browserSee and load images or movies that you want to display inside of the Plane track. Note that this image needs to exist already so that it gets displayed in the list. As a image node for example.
Edit BoxThe name of the current active image or movie. Click at it to change the name.

Fake User

Wit this button you assign a fake user to this selected mask. Masks gets created with a fake user already. Means when you save the scene and reopen it, then this mask will still be there.

Data, like images, that is not longer linked to anything else gets removed when you save and reload a scene. Bforartists has the concept of fake users to go around this behaviour. An image with a fake user is in fact linked to something. And so it is not lost when you save and reload the scene.

EntryWhat it does
New ImageCalls a file browser to choose a image or movie.
RemoveRemoves the current active image or movie. It is still in the Image browser though. To delete it completely you can use the Purge command in the File menu in the Cleanup submenu. See also Fake User.

Opacity

The opacity of the image or movie.

Track tab - Tracking Settings Panel

Track tab - Tracking Settings Panel
Track tab - Tracking Settings Panel

This content is visible when you have at least one of the markers selected.

Motion Model

Motion Model

Choose the motion model for the marker.

Match

Match

Choose the pattern match method.

EntryWhat it does
PrepassUse a brute-force translation only pre-track before refinement.
NormalizeNormalize light intensities while tracking.

Tracking Options Extras

Tracking Options Extras

A sub menu that contains some not so often used settings.

EntryWhat it does
CorrelationDefault minimum value of correlation between matched pattern and reference that is still treated as successful tracking.
MarginDefault distance from image boundary at which markers stops tracking.
Use MaskUse a Grease Pencil data block as a mask.
Frames LimitIn every tracking cycle the numbers of given frames are tracked.

Speed

Speed

A drop down box to choose the tracking speed. This is just a preview feature. The tracking quality is not affected.

Track tab - Camera Panel

Track tab - Camera Panel
Track tab - Camera Panel

The settings for the camera with which you have recorded the footage movie. Every camera has some specific settings. And this needs to be calculated too to match the footage to the 3D content.

Presets

Presets

A drop down box to choose between different camera presets. When your camera is not listed then you need to do the settings manually.

Add Camera Preset

Add Camera Preset

This is at the end of the list. Add a new preset, and give it a name. To remove the preset click at the minus sign besides the preset in the list

EntryWhat it does
Sensor WidthThe width of the CCD Sensor in your used camera. This value can be found in the camera specifications.
Pixel AspectThe Pixel Aspect ratio of the CCD Sensor in your used camera. This value can be found in the camera specifications. This value can also be guessed. For example, when the footage should be 1920×1080, but the images themselves are 1280×1080, then the pixel aspect is: 1920 / 1280 = 1.5.

Track tab - Camera Panel - Lens Subpanel

Track tab - Camera Panel - Lens Subpanel
Track tab - Camera Panel - Lens Subpanel

This panel belongs to the Camera panel above. Type in your lens values from the camera with which you have recorded your footage movie.

Focal length

The focal length units with which the movie was shot. You can choose between millimeter and pixel.

Units

Units

The units to use for the camera focal length.

EntryWhat it does
Optical centerThe optical center. Usually in the middle of the movie. But some cameras also have an offset here. In most cases it is equal to the image center, but it can be different in some special cases. Check camera/lens specifications in such cases. To set the optical center to the center of image, there is a Enter button below the sliders.
Set CenterCenter the optical center.

Lens Distortion

Lens Distortion

The lens distortion of your camera. You can choose between two distortion models. Polynomial and Divisions.

Basically, just tweak K1 until solving is most accurate for the known focal length (but also take grid and grease pencil into account to prevent “impossible” distortion).

The brown model also provides P1 and P2 values.

Lens Distortion
Lens Distortion
Lens Distortion
Lens Distortion

Track tab - Marker Options Panel

Track tab - Marker Options Panel
Track tab - Marker Options Panel

The Marker panel contains the settings for the selected marker(s). Here you can also enable or disable the marker.

EntryWhat it does
EnabledEnable the selected marker(s).
PositionThe position of the selected marker(s) in pixel. Zero is down left.

Offset

Offset

You can give the marker handler an offset. So that it gets displayed besides the marker.

Pattern Area

Pattern Area

The handler size.

Search Area

Search Area

The size and position of the search area for this marker for tracking.

The search area can be turned on in the Clip Display options in the header up right.

Tracking Mode › Stabilization Tab

Tracking Mode - 2D Stabilization Panel

Tracking Mode - 2D Stabilization Panel
Tracking Mode - 2D Stabilization Panel
Tracking Mode - 2D Stabilization Panel
Tracking Mode - 2D Stabilization Panel

The purpose of 2D Stabilization is to smooth out jerky camera handling on existing real world footage. To activate the 2D stabilizer, you need to set the toggle in the panel, and additionally you need to enable Show Stable in the Display panel. Then you’ll need to set up some tracking points to detect the image movements. And you need to set a proper starting point, the anchor frame.

Tracking Mode - 2D Stabilization Panel
Tracking Mode - 2D Stabilization Panel

Anchor Frame

The first frame of the stabilization.

Rotation / Scale

Rotation / Scale

Normally you just stabilize the position. Here you can stabilize rotation and scale too. Note that you can't activate scale independently here. It appears when you activate Rotation.

Tracks for Location

The list of markers that gets used for location stabilization.

With the plus and minus button at the right you can add selected markers, or remove the markers from the list.

Tracks for Rotation/Scale

Tracks for Rotation/Scale

The list of markers that gets used for rotation/scale stabilization.

With the plus and minus button at the right you can add selected markers, or remove the markers from the list.

This list is just visible when you have at least Rotation activated.

Autoscale

Autoscale

The stabilization will lead to areas where the movie doesn't show at the canvas anymore. Autoscale scales the content so that the whole canvas is covered again.

Max

Max

The maximum value for Autoscale. This slider appears when you activate Autoscale.

Expected Position

EntryWhat it does
X / YThe position of the movie at the canvas.
Expected RotationRotate the movie at the canvas manually.
Expected ScaleScale the movie at the canvas manually. Note that this slider is not showing when you have Autoscale activated.

Influence

Influence

The influence of stabilization algorithm. You can independently adjust location, rotation and scale. When you have rotation off, then the sliders for rotation influence and scale influence are not showing.

Interpolate

Interpolate

Adjust the interpolation mode for images. For rotation and scale the images needs to be recalculated.

Tracking Mode › View Tab

Tracking Mode - View tab
Tracking Mode - View tab

Just shows in Mask mode. Tracking has no 2D cursor.

This panel shows the location of the 2d cursor, based at the lower left corner of the footage image. The edit boxes also allows you to set the cursor position by numeric values.

Preface

Note that the correct mode is Tracking Mode in Clip View. In Graph and Dope sheet View there is no sidebar.

Note also that some panels exists in both modes, tracking and masking.

Annotations Panel

Annotations Panel
Annotations Panel

The Annotations panel is the place to manage the Annotation layers and materials.

When you don't have drawn an annotation yet then the panel just contains a New button.

Clip / Track

Where the Grease Pencil comes from. From the movie Clip, or from a track.

Annotations prop

Annotations prop

Add, remove and rename new annotations.

Drop down box

A list of the available annotation layers.

EntryWhat it does
Edit BoxThe name of the current annotation. You can rename the annotation to your needs here.
Fake UserAssign a fake user to this annotation. Fake users is an odd concept to keep data in the scene even if it has no user somewhere. The fake user is then a dummy user so that the object is not deleted when saving the scene.
Add AnnotationAdd a new annotation.
Delete AnnotationDelete the annotation.

List of Annotation Strokes

List of Annotation Strokes
List of Annotation Strokes

A list of the Annotation layers for the current Annotation. Every layer can have an own color.

At the right side you find buttons to sort them and to add and remove new Annotation layers.

You can change the color by clicking at the color field. A color dialog will pop up. You can rename annotation layers by double clicking at it.

The eye icon allows you to make it invisible And it has a search field.

EntryWhat it does
ThicknessThe thickness of the annotation stroke.
Frame Locked/UnlockedLock frame displayed by current layer. This toggles whether the active layer is the only one that can be edited. · Delete Active Frame: This feature is active when there is an animation. Delete the active frame from the active annotations layer.