View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Header

The Header contains various menus, navigation elements, settings and tools for the viewport.

40
 min read
Up to date for 
5.1
draft

Movie Clip Editor - Header

The Header contains various menus, navigation elements, settings and tools for the viewport.

The header is divided into two areas. Left menus. Right settings.

Movie Clip Editor - Header
Movie Clip Editor - Header

The Movie Clip Editor is three editors in one. And the Clip editor in mask mode looks also different. So we need to explain the content for all three editor types plus the sub mode mask.

Movie Clip Editor - Header
Movie Clip Editor - Header

Header right click menus

The general right click menu functionality is explained in chapter 6 Editors introduction.

Editortype Menu

Editortype Menu

Bforartists is made of several editor types. Headers can display a menu where you can switch to other editor types.

This menu is hidden by default. It is meant to edit the layouts, and should not be necessary for regular work. You can reveal it in the header right click menu.

Editortype Menu

Header Tools and Options

Movie Clip Editor - Header

The Movie Clip Editor has two modes, and is three editors in one. So we have to explain the single header tools and options at a one by one base.

Movie Clip Editor - Header
Movie Clip Editor - Header

Tracking mode - Clip submode

Tracking mode - Clip submode
Tracking mode - Clip submode

Movie Clip property

Movie Clip property
Movie Clip property

Available in Tracking in Clip mode and Mask mode.

This property contains the list of loaded movie clips. When no movie clip is loaded or active, then it displays the Open Buttons. When a movie clip is loaded and active, then it displays the name of the currently active movie clip.

From left to right ...

Movie Clip property
EntryWhat it does
List of clips in the sceneThis is a list of the movie clips in the scene. Allows you to witch to other images. · Search form: Search for specific clips.
Clip Edit BoxThe name of the currently selected movie clip. You can rename the movie clip here too.
Number of Fake UsersIn case this file has a fake user assigned, then this number displays the number of fake users.
Fake UserWith this button you assign a fake user to this selected image. Data, like images, that is not longer linked to anything else gets removed when you save and reload a scene. Bforartists has the concept of fake users to go around this behavior. An image with a fake user is in fact linked to something. And so it is not lost when you save and reload the scene.
OpenOpen a new movie clip.

Remove

Removes the movie clip. Note that it will not be removed when it has a fake user assigned. Then the clip becomes simply inactive. You can still use it from the list again.

Pivot Point

Pivot Point

Adjust the pivot point for transform operations. The names should be self explaining.

Solve Error

Read only. The solve error for the current tracking.

Toggle Lock Selection

Toggle Lock Selection
Toggle Lock Selection

With lock to selection disabled the viewport stands still and the markers moves. With lock to selection enabled the view is centered at the current selected marker, and the video moves around.

Available in Tracking in Clip mode and Mask mode.

Clip Display

Clip Display

Display options for the tracking footage.

EntryWhat it does
R G BDisplay the red green and blue channels of the footage
BWDisplay the footage in black and white.
Mute FootageHide the footage.
Render UndistortedRender Preview undistorted.
Show MetadataShows the metadata of the clip if available.
Show StableShow stable footage in editor. Stabilization needs to be enabled.
GridDisplays a red grid over the footage that displays the lens distortion.
Aspect Ratio X YThe aspect ratio to display the footage.

Tracking mode - Graph submode

Tracking mode - Graph submode
Tracking mode - Graph submode

Tools to refine and modify the markers.

Refine Markers Backwards

Refine Markers Backwards

Refine selected markers position by running the tracker from tracks reference to current frame.

EntryWhat it does
Clear Track Path BackwardsClear tracks before the current position.
Track Markers BackwardsTrack selected markers backwards.
Track Markers Sequence BackwardsTrack selected marker sequence backwards.
Track Markers Sequence ForwardsTrack selected marker sequence forwards.
Track Markers ForwardsTrack selected markers forwards.
Clear Track Path ForwardsClear tracks after the current position.
Refine Markers ForwardsRefine selected markers position by running the tracker from tracks reference to current frame.
Only selectedOnly display channels relating to the current objects and data.
Display HiddenDisplay also channels from objects/bones that are not visible.
Show FramesShow curve for per frame average error. Camera motion should be solved first.
Show Track MotionDisplay the speed curves for the selected tracks. Red is X direction. Green is Y direction.
Show Tracks ErrorDisplay the reprojection error curve for the selected tracks.
Show GizmoDisplay gizmos.

Gizmos

Gizmos

Viewport Gizmos

Show the navigate viewport gizmos.

Tracking mode - Dope Sheet submode

Tracking mode - Dope Sheet submode
Tracking mode - Dope Sheet submode

Tools to refine and modify the markers.

Refine Markers Backwards

Refine Markers Backwards

Refine selected markers position by running the tracker from tracks reference to current frame.

EntryWhat it does
Clear Track Path BackwardsClear tracks before the current position.
Track Markers BackwardsTrack selected markers backwards.
Track Markers Sequence BackwardsTrack selected marker sequence backwards.
Track Markers Sequence ForwardsTrack selected marker sequence forwards.
Track Markers ForwardsTrack selected markers forwards.
Clear Track Path ForwardsClear tracks after the current position.
Refine Markers ForwardsRefine selected markers position by running the tracker from tracks reference to current frame.
Only selectedOnly display channels relating to the current objects and data.
Display HiddenDisplay also channels from objects/bones that are not visible.

Dope Sheet Sort Field

Dope Sheet Sort Field
Dope Sheet Sort Field

The method to sort the channels in dope sheet view.

Invert Dope Sheet Sort

Invert the dope sheet sorting.

Options panel

Options panel

Show Seconds

Option. Display the timeline numbering in seconds instead of frames.

Show Seconds

Sync Visible Range

Option. Synchronize the visible timeline range with other time based editors.

Gizmos

Gizmos

Viewport Gizmos

Show the navigate viewport gizmos.

Mask mode

Mask mode

Movie Clip property

Movie Clip property
Movie Clip property

Available in Tracking in Clip mode and Mask mode.

This property contains the list of loaded movie clips. When no movie clip is loaded or active, then it displays the Open Buttons. When a movie clip is loaded and active, then it displays the name of the currently active movie clip.

From left to right ...

Movie Clip property
EntryWhat it does
List of clips in the sceneThis is a list of the movie clips in the scene. Allows you to witch to other images. · Search form: Search for specific clips.
Clip Edit BoxThe name of the currently selected movie clip. You can rename the movie clip here too.
Number of Fake UsersIn case this file has a fake user assigned, then this number displays the number of fake users.
Fake UserWith this button you assign a fake user to this selected image. Data, like images, that is not longer linked to anything else gets removed when you save and reload a scene. Bforartists has the concept of fake users to go around this behavior. An image with a fake user is in fact linked to something. And so it is not lost when you save and reload the scene.
OpenOpen a new movie clip.

Remove

Removes the movie clip. Note that it will not be removed when it has a fake user assigned. Then the clip becomes simply inactive. You can still use it from the list again.

Remove

Mask Property

These are display options for mask overlays.

Mask Display

Spline
Spline

Display spline overlays.

EntryWhat it does
Edge DisplayChanges the spline overlay to outline, dash, black or white edges.
OverlayDisplays an overlay overlays.
Overlay Mode
Overlay Mode

Show combined color channels or alpha channel. When using combined, the Blending Factor slider can be changed.

Pivot Point

Pivot Point

Adjust the pivot point for transform operations. The names should be self explaining.

Proportional Editing

Proportional Editing

Enables proportional editing.

Proportional Editing is a way of transforming selected elements (such as vertices, or in this case the handlers for the mask spline curves) while having that transformation affect other nearby elements with a falloff. For example, moving a single vertex will move unselected vertices within a given range. And the falloff means that selected vertices that are closer to the selected vertex will move more than those farther from it.

Settings

Choose between different falloff methods for the proportional editing. The settings are hidden when you have proportional editing off.

Toggle Lock Selection

Toggle Lock Selection of the current clip editor

Clip Display

Clip Display

Display options for the tracking footage.

EntryWhat it does
R G BDisplay the red green and blue channels of the footage
BWDisplay the footage in black and white.
Mute FootageHide the footage.
Render UndistortedRender Preview undistorted.
Show MetadataShows the metadata of the clip if available.
Show StableShow stable footage in editor. Stabilization needs to be enabled.
GridDisplays a red grid over the footage that displays the lens distortion.
Aspect Ratio X YThe aspect ratio to display the footage.

Gizmos

Gizmos

Viewport Gizmos

Show the navigate viewport gizmos.

Show Overlays

Show Overlays

Viewport Overlays

Guides
EntryWhat it does
Distortion GridShow grid showing lens distortion.
CursorDisplay 2d cursor.
AnnotationsDisplay annotations.
Mask Display
Mask Display
Spline

Edge Display type

Edge Display type

How to display the spline.

Overlay
Overlay
EntryWhat it does
Alpha ChannelShow the alpha channel of the mask
CombinedCombine space background image with the mask · Blending Factor: The blending factor between mask and space background.

Quick Menu

Quick Menu

Quick Menu

The quick menu, or in long Quick Favorites menu, is a menu that can be customized to your needs. Here you can add operators for quick access.

It is located in the header. But it can be called by hotkey Q directly under the mouse. This hotkey works in other editors too.

When the menu is empty, then you will see the message "No Menu Items found". This means that you first have to add some tools to the menu. It is a user configurable menu.

Note that added operators in this menu does not have icons. Just text.

Adding an operator to the Quick menu

Adding an operator to the Quick menu
Adding an operator to the Quick menu

Open the panel or the menu where your operator is that you want to add.

Let's add the open command from the File menu. Open the File menu, right click at open, and choose Add to Quick Favorites.

Do the same with Save As. We should now have two new menu items in the Quick menu, which you can use now.

Adding an operator to the Quick menu
Adding an operator to the Quick menu

As a rule of thumb, when the right click menu has an Add to Quick Favorites, then you can add it to the quick menu.

Note that you can also add operators from the tool shelf at the left. And also operators from other editor types. Some other editors have their own quick menu though. The Image Editor for example. These operators gets added in the quick menu of the image editor then. And does not show in the quick menu in the header of the 3D view.

Adding a menu to the Quick menu

Adding a menu to the Quick menu
Adding a menu to the Quick menu

It is also possible to add a menu to the Quick menu. For example the whole Add menu. The way is the same. Right click at it, and choose Add to Quick Favorites.

Adding a menu to the Quick menu
Adding a menu to the Quick menu

Order

You might notice that the add menu adds at the top of the menu, and not at the bottom as you would expect. First comes menus, then comes operators. And they get added in the order in which you add them.

Besides that, operators and menus gets added in the order that you add them. They cannot be sorted afterwards. So be careful how you add them. You can of course always remove operators and menus, and re-add them at the end of the list.

Removing an operator from the Quick menu

The Quick Favorites menu (Q) holds the tools and menus you add to it yourself. See Quick Favorites in the Interface chapter.

Context and mode dependent content

The quick favorites. menu exists in nearly all editors. But it is just in the 3D view available in the header. So that you know this functionality exists. In the other editors you call it with hotkey Q.

The content of the quick favorites. menu changes, dependent over which editor you are, and in what mode you are. When you add for example an operator from the image editor, then this operator just shows in the quick menu when you call the menu from the image editor. Same goes for the modes. Edit mode tools will just show in edit mode. And so on.

View Menu

Movie Clip Editor Modes

The Movie Clip Editor is three editors in one. And the Clip editor in mask mode looks also different. So we need to explain the content for all three editor types plus the Mask mode.

Movie Clip Editor Modes
Movie Clip Editor Modes

View Menu in Tracking mode in Clip sub mode

View Menu in Tracking mode in Clip sub mode
View Menu in Tracking mode in Clip sub mode

The View menu contains all View related tools.

Toolbar

Toolbar

Shows or hides the toolbar at the left.

Sidebar

Shows or hides the sidebar at the right in the viewport.

Adjust Last Operation - View Menu in Tracking mode in Clip sub mode

Adjust Last Operation

Shows the adjust last operation panel down left.

EntryWhat it does
Frame SelectedZooms to the selection.
View AllView all zooms in or out in the viewport until all selected objects are displayed fitting in the viewport.
View FitView all zooms in or out in the viewport to fit the current selection into the viewport.
Center View to CursorCenter Cursor centers the view to the 2D cursor.

Annotations (Legacy) submenu

Annotations (Legacy) submenu

This group of operators is useful to take notes without changing tool-shelf operators. These notes can be colored in the View tab of the Property Shelf. Each layer is a single color. You can also animate the notes with keyframes, editable in the dopesheet.

Note: These are legacy operators, meaning they are equally available in the Toolshelf as a modal operator.

EntryWhat it does
Draw AnnotationStarts the annotation free hand draw tool in the editor.
Draw Line AnnotationStarts the annotation line draw tool to draw straight lines in the editor.
Draw Polyline AnnotationStarts the annotation Polyline draw tool in the editor which allows to draw multiple connected straight lines in the editor.
Erase AnnotationStarts the annotation erase tool in the editor which erases any strokes in the editor.
Add Annotation LayerStarts a new annotation layer.
Erase Annotation Active KeyframeErases the active keyframe of the annotation.
EntryWhat it does
Frame SelectedCenters the view at the current frame(s).
Frame AllViews all content, zoomed in to fit into the viewport.
View FitView whole image with markers.
Center View to CursorCenter the view so that the 2d cursor is in the middle of the view.
Zoom InZooms into the view.

Zoom Out

Zoom Out

Zooms out of the view.

Zoom submenu

A set of predefined zoom factors.

Pie menus

Pie menus

Lists the available pie menus, and gives you the ability to read the hotkeys and assign own hotkeys.

Area

Area

This menu contains general view functionality. And exists in most other editor types too.

EntryWhat it does
Horizontal SplitSplits the current view horizontally into two independent editor windows.
Vertical SplitSplits the current view vertically into two independent editor windows.

Duplicate Area into New Window

Duplicate Area into New Window
Duplicate Area into New Window

Duplicate Area into New Window opens this editor in a floating window. See Floating editor windows in the Interface chapter.

EntryWhat it does
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaClose the area window.

View Menu in in Tracking mode in Graph sub mode

View Menu in in Tracking mode in Graph sub mode
View Menu in in Tracking mode in Graph sub mode

The View menu contains all View related tools.

EntryWhat it does
Frame SelectedCenters the view at the current frame(s).
Frame AllViews all content, zoomed in to fit into the viewport.
Zoom In + Zoom OutZoom in and out in the viewport.

Pie menus

Pie menus

Lists the available pie menus, and gives you the ability to read the hotkeys and assign own hotkeys.

Area

Area

This menu contains general view functionality. And exists in most other editor types too.

EntryWhat it does
Horizontal SplitSplits the current view horizontally into two independent editor windows.
Vertical SplitSplits the current view vertically into two independent editor windows.

Duplicate Area into New Window

Duplicate Area into New Window
Duplicate Area into New Window
EntryWhat it does
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaClose the area window.

View Menu in in Tracking mode in Dopesheet sub mode

View Menu in in Tracking mode in Dopesheet sub mode
View Menu in in Tracking mode in Dopesheet sub mode

The View menu contains all View related tools.

EntryWhat it does
Frame AllShow all content, zoomed to fit into the viewport.
Zoom In + Zoom OutZooms in and out in the viewport.

Pie menus

Pie menus

Lists the available pie menus, and gives you the ability to read the hotkeys and assign own hotkeys.

Area

Area

This menu contains general view functionality. And exists in most other editor types too.

EntryWhat it does
Horizontal SplitSplits the current view horizontally into two independent editor windows.
Vertical SplitSplits the current view vertically into two independent editor windows.

Duplicate Area into New Window

Duplicate Area into New Window
Duplicate Area into New Window
EntryWhat it does
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaClose the area window.

View Menu in Mask mode

View Menu in Mask mode
View Menu in Mask mode

The View menu contains all View related tools.

Toolbar

Toolbar

Shows or hides the toolbar at the left.

Sidebar

Shows or hides the sidebar at the right in the viewport.

Adjust Last Operation - View Menu in Mask mode

Adjust Last Operation

Shows the adjust last operation panel down left.

Annotations (Legacy) submenu

Annotations (Legacy) submenu

This group of operators is useful to take notes without changing tool-shelf operators. These notes can be colored in the View tab of the Property Shelf. Each layer is a single color. You can also animate the notes with keyframes, editable in the dopesheet.

Note: These are legacy operators, meaning they are equally available in the Toolshelf as a modal operator.

EntryWhat it does
Draw AnnotationStarts the annotation free hand draw tool in the editor.
Draw Line AnnotationStarts the annotation line draw tool to draw straight lines in the editor.
Draw Polyline AnnotationStarts the annotation Polyline draw tool in the editor which allows to draw multiple connected straight lines in the editor.
Erase AnnotationStarts the annotation erase tool in the editor which erases any strokes in the editor.
Add Annotation LayerStarts a new annotation layer.
Erase Annotation Active KeyframeErases the active keyframe of the annotation.
EntryWhat it does
Set 2D CursorThe 2D cursor is the center for mask creation and modification. Hotkey only tool! Please use the hotkey!
Frame SelectedZooms to the selection.
Frame AllView all zooms in or out in the viewport until all selected objects are displayed fitting in the viewport.
View FitView all zooms in or out in the viewport to fit the current selection into the viewport.
Center View to CursorCenter Cursor centers the view to the 2D cursor.

Zoom In

Zooms into the view.

Zoom Out

Zooms out of the view.

Zoom

Zoom

A set of predefined zoom factors.

Pie menus

Pie menus

Lists the available pie menus, and gives you the ability to read the hotkeys and assign own hotkeys.

Area

Area

This menu contains general view functionality. And exists in most other editor types too.

EntryWhat it does
Horizontal SplitSplits the current view horizontally into two independent editor windows.
Vertical SplitSplits the current view vertically into two independent editor windows.

Duplicate Area into New Window

Duplicate Area into New Window
Duplicate Area into New Window
EntryWhat it does
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaClose the area window.

Select Menu

Movie Clip Editor Modes

Movie Clip Editor Modes
Movie Clip Editor Modes

The Movie Clip Editor is three editors in one. And the Clip editor in mask mode looks also different. So we need to explain the content for all editor types plus the Mask mode that has a Select menu.

The Dope sheet mode has no Select menu.

Select Menu in Tracking mode in Clip sub mode

All

All

Select everything.

EntryWhat it does
NoneSelect nothing.
InverseInvert the current selection.
Box SelectDraw a rectangle to box select markers. It adds to selection by default. To subtract from selection hold down Shift key.
Circle SelectCircle select enters the Circle Select mode. This is a special select mode where you can select elements by moving with the mouse over it. It adds to selection by default. To subtract from selection hold down Shift key. To exit the Circle select click with the right mouse button. The pencil radius of the circle select tool can be adjusted with the scroll wheel.

Lasso Select

Lasso Select

A sub menu with the available lasso select modes.

Grouped

Grouped

Here you can select objects that are in the same group by the chosen method. The items should be self explaining.

EntryWhat it does
Select Stabilization tracksSelect the tracks that are used for translation stabilization.
Select Stabilization Rotation tracksSelect the tracks that are used for rotation stabilization.

Select Menu in Tracking mode in Graph sub mode

All

All

Select everything.

EntryWhat it does
NoneSelect nothing.
InverseInvert the current selection.

Select Menu in Mask mode

Select Menu in Mask mode
Select Menu in Mask mode

Note that you need to have a mask so that the content becomes active.

EntryWhat it does
AllSelect everything.
NoneSelect nothing.
InverseInvert the current selection.
Box SelectDraw a rectangle to box select markers. It adds to selection by default. To subtract from selection hold down Shift key.
Circle SelectCircle select enters the Circle Select mode. This is a special select mode where you can select elements by moving with the mouse over it. It adds to selection by default. To subtract from selection hold down Shift key. To exit the Circle select click with the right mouse button. The pencil radius of the circle select tool can be adjusted with the scroll wheel.

Lasso Select

Lasso Select

A sub menu with the available lasso select modes.

EntryWhat it does
LinkedSelect all curve points that are linked to the already selected points.
More/Less SubmenuMore: Increase the selection by one point. · Less: Decrease the selection by one point.

Tracking Mode › Clip Submode › Clip Menu

Clip Menu

Open Clip

Open Clip

Opens an Image Sequence or a movie clip.

EntryWhat it does
Set Scene FramesSet the start and end frame of the frames to match the start and end frame of the clips.
Prefetch FramesPrefetch frames from disk for faster playback and/or tracking.
Reload ClipReloads the movie clip.
Set as BackgroundSet the current movie clip as the camera background in the 3d view.
Setup Tracking ScenePrepare the scene fro compositing 3d objects into this footage.

Tracking Mode › Clip Submode › Track Menu

Track Menu

Track Menu

Contains tracking functionality. Note that lots of this content is currently a double entry to the content in the tool shelf. The tool shelf content will most probably vanish in the future, in favour of a tool shelf with buttons like in the 3d view.

Transform submenu

Transform submenu

Track navigation.

Move

Move the selected track(s).

Adjust Last Operation - Move
Last Operator Move
Move X, Y Z

The position. Attention, the actual world orientation and rotation does not matter here. It always starts with a value of zero, and moves relative to this zero then. For the actual location values have a look in the sidebar in the transform panel.

Orientation
Orientation

The widget can have different orientations. The menu items should be self explaining.

Mirror Editing

Enables mirror editing.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Rotate

Rotate the selected tracks.

Adjust Last Operation - Rotate
Last Operator Rotate
EntryWhat it does
AngleThe rotation. Attention, the actual world orientation and rotation does not matter here. It always starts with a value of zero, and rotates relative to this zero then. For the actual rotation values have a look in the sidebar in the transform panel.
AxisWhich axis to rotate.
Orientation
Orientation

The widget can have different orientations. The menu items should be self explaining.

Mirror Editing

Enables mirror editing.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Resize

Resize

Resize the selected track(s).

Adjust Last Operation - Resize
Last Operator Resize
EntryWhat it does
AngleThe rotation. Attention, the actual world orientation and rotation does not matter here. It always starts with a value of zero, and rotates relative to this zero then. For the actual rotation values have a look in the sidebar in the transform panel.
AxisWhich axis to rotate.
Orientation
Orientation

The widget can have different orientations. The menu items should be self explaining.

Mirror Editing

Enables mirror editing.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Track Motion submenu

Track Motion submenu
EntryWhat it does
BackwardsTrack backwards the whole range.
Frame BackwardsTrack backwards frame wise.
ForwardsTrack forwards the whole range.
Frame ForwardsTrack forwards frame wise.

Clear submenu

Clear submenu
EntryWhat it does
BeforeClears track paths before the current position.
AfterClears track paths after the current position.
Track PathClears the currently active Track Path.
SolutionClears all calculated data.
EntryWhat it does
Refine submenuBackwards: Refine selectet marker positions forwards. · Backwards: Refine selectet marker positions forwards.
Add MarkerAdd a marker. The marker will appear under the mouse, and stick until you click.

Detect Features

Detect Features

Adds automatically markers at the current movie position, and tries to detect marcant areas in the current frame that are useful for tracking. It also sets keyframes at this position.

When enough marcant areas are available then it adds up to eight markers that way.

Detect Features

Adjust Last Operation - Detect Features

Last Operator Detect Features
Last Operator Detect Features
Placement

Placement is a drop down box where you can limit the placement of the markers.

Whole frame
Whole frame

The markers can be at every position of the current frame image.

EntryWhat it does
Inside Grease PencilThe markers have to be inside the Grease Pencil.
Outside Grease PencilThe markers have to be outside Grease Pencil.
EntryWhat it does
MarginGives a margin to the border of the frame image. Markers have to stay away from the border by the given amount.
ThresholdThe threshold level to consider the current position of the marker as good enough for tracking.
DistanceThe minimum distance between two markers.

Create Plane Track

Creates a plane track. A plane track can be used to map an image or a movie at an area in your clip. The Plane track.

New Image from Plane Marker

New Image from Plane Marker
New Image from Plane Marker

Create new image from the content of the plane markerfrom the pixels of the movie clip that the plane marker “sees” at the current frame. This allows you to create and impose an un-warped texture of any flat surface in the footage.

To use, create and select four tracking points then create a Plane Marker. Once you’ve selected the Plane Marker, create the new image - then edit the image in the Image Editor.

Update Image from Plane Marker

Update current image used by plane marker from the content of the plane marker. This updates the pixels of the active Plane Track’s image.

Allows you to update the texture of any flat surface in the footage.

Solve Camera Motion

Starts the calculation for the camera motion to match the track motion.

There should be at least eight common tracks on the both of the selected keyframes.

There should be noticeable parallax effects between these two keyframes.

The average re-projection error is reported to the information space and to the clip editor header. Re-projeciton error means the average distance between reconstructed 3D position of tracks projected back to footage and original position of tracks. Re-projection error below 0.3 means accurate re-projection, (0.3 - 3.0) means quite nice solving which still can be used. Values above 3 means some tracks should be tracked more accurately, or that values for focal length or distortion coefficients were set incorrectly.

EntryWhat it does
Join TracksJoins selected tracks.
Average TracksAverage selected tracks into active.
Copy TracksCopy selected tracks to clipboard.
Paste TracksPastes selected tracks from clipboard.
Copy Settings to DefaultsCopies track settings from active track to default settings.
Apply default settingsCopy tracking settings form active tracks to selected tracks. You need to select the source track first, then hold down shift, then select the target track. Then perform copy track settings.

Animation submenu

Animation submenu

Insert Keyframe

Insert Keyframe

Inserts a keyframe at current position in spreadsheet sub mode panel.

Delete Keyframe

Deletes keyframes at current position in dope sheet sub mode panel.

Show/Hide submenu

Show/Hide submenu

Show or hide tracks.

EntryWhat it does
Show HiddenShow all hidden tracks.
Hide SelectedHide the selected tracks.
Hide UnselectedHide the unselected tracks.

Adjust Last Operation - Hide Tracks

Last operator Hide Tracks
Last operator Hide Tracks
Unselected

Hide selected or unselected tracks.

Clean up submenu

Clean up submenu
EntryWhat it does
Clean TracksClean tracks with high error values or few frames.
Filter TracksFilter out tracks that has weird looking spikes in motion curves.
EntryWhat it does
Delete TrackDelete the selected track.
Delete MarkerDelete the selected marker.

Reconstruction

Reconstruction
EntryWhat it does
Set OriginSet active marker as origin in 3D space.
Set FloorSet plane in the 3D space as a Floor plane, based at three selected markers. You need to have three markers selected. Or you will get an error message.

Set Wall

Set plane in the 3D space as a Wall plane, based at three selected markers.

Adjust Last Operation - Set Plane
Last Operator Set Plane
Last Operator Set Plane
Plane
Plane

A drop down box to choose if you want to set the selected markers as plane or as floor.

Set X Axis

Set X axis rotation in 3D space, based at the selected marker. You need to have one marker selected. Or you will get an error.

Set Y Axis

Set X axis rotation in 3D space, based at the selected marker. You need to have one marker selected. Or you will get an error.

Adjust Last Operation - Set Axis
Last Operator Set Axis
Last Operator Set Axis
Axis

A drop down box to choose if you want to use the axis to X or to Y

Set Scale

Set scale of scene by scaling camera, based at two selected markers. You need to have two markers selected. Or you will get an error.

Adjust Last Operation - Set Scale
Last Operator Set Scale
Last Operator Set Scale
Distance

The distance between two bundles used for scene scaling.

Apply Scale

Apply scale to solution.

Adjust Last Operation - Apply Solution Scale
Last operator Apply Solution Scale
Last operator Apply Solution Scale
Distance

The distance between two bundles used for scene scaling.

EntryWhat it does
3D Markers to MeshCreates a vertex cloud using the coordinates of the reconstructed tracks.
Link Empty to TrackCreates an Empty which will be copying movement of active track.

Tracking Mode › Graph Submode › Graph Menu

Track Menu

Delete Curve

Delete Curve

Deletes the track that correspondent to the current curve.

Delete Knot

Deletes the selected curve points.

Clear Track Path Remained

Clear Track Path Remained
Clear Track Path Remained

Clears the track path after the current position.

Clear Track Path Up To

Clear Track Path Up To
Clear Track Path Up To

Clears the track path up to the current position.

EntryWhat it does
Clear Track Path AllClears the complete track path.
Disable MarkersDisables the selected curve points.
MoveMoves the selected curve points.
RotateRotates the selected curve points.
ResizeScales the selected curve points.

Mask Mode › Clip Menu

Clip Menu

Open Clip

Open Clip

Opens an Image Sequence or a movie clip.

EntryWhat it does
Set Scene FramesSet the start and end frame of the scene to match the start frame and length of the clip.
Prefetch FramesPrefetch frames from disk for faster playback and/or tracking.
Reload ClipReloads the movie clip.
Set as BackgroundSet the current movie clip as a camera background in the 3d viewport.
Setup Tracking ScenePrepare Scene for compositing 3d opbjects into this footage.

Mask Mode › Add Menu

Add Menu

Add Menu

Masking can be done by using curves. In the Add menu you will find two spline primitives. You can choose between a circle Bezier curve object and a square Bezier curve object.

You select curve points by clicking with the left mouse button at them. Holding down Shift will add to the selection. Clicking in the off will deselect everything.

Circle

Circle

Adds a Bezier circle that you can use for masking.

Circle

This circle element can be modified by right clicking at the handlers and pulling at the handlers until the desired result is achieved. The yellow points are handlers. The whole curve can be moved around with right mouse button. See also Transform sub menu in the Mask menu.

Adjust Last Operation - Add Circle

Last Operator Add Circle
Last Operator Add Circle
EntryWhat it does
SizeThe size of the circle.
Location X YThe location of the circle.

Square

Square

Adds a Bezier circle that you can use for masking.

Square

This circle element can be modified by right clicking at the handlers and pulling at the handlers until the desired result is achieved. The yellow points are handlers. The whole curve can be moved around with right mouse button. See also Transform sub menu in the Mask menu.

Adjust Last Operation - Add Square

Last Operator Add Square
Last Operator Add Square
EntryWhat it does
SizeThe size of the circle.
Location X YThe location of the circle.

Add Vertex and Slide

Add Vertex and Slide
Add Vertex and Slide

You can add more curve points by holding down ctrl and clicking left at a curve.

You can create a spline from scratch with this method too. Simply hold down Ctrl, click into the viewport, and created your needed spline points. To close the created mask spline use Toggle Cyclic from the mask menu.

Adjust Last Operation - Add Vertex and Slide

Last operator Add Vertex and Slide
Last operator Add Vertex and Slide
Location X Y

The location of the created spline point.

Feather Vertex Slide

Feather Vertex Slide

Add new vertex to feather and slide it. Hotkey only tool !

Adjust Last Operation - Add Feather Vertex and Slide

Last Operator Add Feather Vertex and Slide
Last Operator Add Feather Vertex and Slide
Location X Y

The location of the circle.

Mask Mode › Mask Menu

Masking preface

Mask Mode - Mask Menu
Mask Mode - Mask Menu

Masks have many purposes. They can be used in a motion tracking workflow to mask out, or influence a particular object in the footage. They can be used for manual rotoscoping to pull a particular object out of the footage. Or as a rough matte for green screen keying. This is done in the Node editor in compositing mode by a mask node.

Masks are independent from a particular image of movie clip. And so they can just as well be used for creating motion graphics or other effects in the compositor.

Masks are defined by splines. Means you work with splines, and you have a bunch of spline tools available.

S-Curves

The curve type used for creating mask splines is almost a Bezier curve. But there are some differences. Smooth edges of the mask are defined by feathering. These are called S-Curves.

Besides the handles, every control point also has points that define the feather between the current point and the next point on the spline. Each feather point is stored in UV space, where U means position across spline segment, and V means distance between main spline and feather points.

Mask Mode - Mask Menu
Mask Mode - Mask Menu

This allows for deforming the main spline in almost any way, and the feather will be updated automatically to reflect that change.

For example if there is just rotation of the spline, feather would stay completely unchanged. If one point’s feather is moved, the other feathers will be automatically stretched uniformly along that segment and the overall shape will be almost the same as artists would want it to be.

Mask Menu

Mask Menu

Transform

Transform

Move

Move the selected curve spline or points.

Adjust Last Operation - Move
Values
Values

Adjust the move amount.

X, Y and Z defines the position.

Axis Ortho

Along which axis to move.

Orientation
Orientation

Orientation is a drop-down box where you can choose the type of orientation for the transform action.

Mirror Editing

Enables mirror editing.

Proportional Editing
Proportional Editing

Proportional Editing is a drop-down box where you can choose to use proportional editing. When you choose one of the active methods then the neighbor geometry gets influenced too in a proportional way.

Proportional Editing Falloff

Proportional Editing Falloff

Proportional Editing Falloff is a drop-down box where you can choose a method for the falloff for the proportional editing.

EntryWhat it does
Proportional sizeProportional size is an edit box to Adjust the strength of the Proportional falloff.
ConnectedJust edit geometry that is directly connected with the current selection. 4 Bforartists 2 Reference Manual - 7.1.4 Editors - 3D View - Header - Navigation Menu
Projected ( 2D)Edit geometry that is in 2d space aligned with the current selection. This one goes from the current view in depth direction.

Rotate

Rotate the selected curve spline or points.

Adjust Last Operation - Rotate
Angle
Angle

Adjust the angle.

Axis
Axis

Along which axis to rotate

EntryWhat it does
OrientationOrientation is a drop-down box where you can choose the type of orientation for the transform action.
Mirror EditingEnables mirror editing.
Proportional Editing
Proportional Editing

Proportional Editing is a drop-down box where you can choose to use proportional editing. When you choose one of the active methods then the neighbor geometry gets influenced too in a proportional way.

Proportional Editing Falloff

Proportional Editing Falloff

Proportional Editing Falloff is a drop-down box where you can choose a method for the falloff for the proportional editing.

EntryWhat it does
Proportional sizeProportional size is an edit box to adjust the strength of the Proportional falloff.
ConnectedJust edit geometry that is directly connected with the current selection. 4 Bforartists 2 Reference Manual - 7.1.4 Editors - 3D View - Header - Navigation Menu
Projected ( 2D)Edit geometry that is in 2d space aligned with the current selection. This one goes from the current view in depth direction.

Scale

Scale the selected curve spline or points.

Adjust Last Operation - Resize
Scale X Y Z
Scale X Y Z
Scale X Y Z

Adjust the scaling.

Orientation
Orientation

Orientation is a drop-down box where you can choose the type of orientation for the transform action.

Mirror Editing

Enables mirror editing.

Proportional Editing
Proportional Editing

Proportional Editing is a drop-down box where you can choose to use proportional editing. When you choose one of the active methods then the neighbor geometry gets influenced too in a proportional way.

Proportional Editing Falloff

Proportional Editing Falloff

Proportional Editing Falloff is a drop-down box where you can choose a method for the falloff for the proportional editing.

EntryWhat it does
Proportional sizeProportional size is an edit box to adjust the strength of the Proportional falloff.
ConnectedJust edit geometry that is directly connected with the current selection. 4 Bforartists 2 Reference Manual - 7.1.4 Editors - 3D View - Header - Navigation Menu
Projected ( 2D)Edit geometry that is in 2d space aligned with the current selection. This one goes from the current view in depth direction.

To Sphere

Shapes a selection of objects into the shape of a sphere. The calculation happens with the object origins.

In Object mode this tools requires to have more than one object selected.

Usage
Usage

Select the objects, activate the tool, then drag the mouse in the 3D viewport. In the header you will read the current factor then. Which tells you how close you are towards the sphere shape.

Adjust Last Operation - To Sphere
Last Operator To Sphere
Last Operator To Sphere
Factor

The factor to transform the selection into a shape form.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Shear

Shear shears the selection.

In Object mode this tools requires to have more than one object selected.

Adjust Last Operation - Shear
Last Operator Shear
Offset

Adjust an offset.

Shear Axis

The shear tool works along a imaginary 2d plane. The shear axis controls if the items are sheared along the x or the y axes of this plane. This is the plane along which the transformation happens. You can shear along the x or the y axis of this plane.

To make things even more complicated, the orientation of this imaginary plane is defined by the Axis and Axis Ortho items below.

EntryWhat it does
AxisDefines one axis of the imaginary shear axis plane.
Axis OrthoDefines the other axis of the imaginary shear axis plane.
Orientation
Orientation

Choose the orientation for the shear action.

EntryWhat it does
Mirror EditingEnables mirror editing.
Proportional editingEnables proportional editing. Activating proportional editing reveals further settings. · Proportional Falloff: Adjust the falloff methods. · Proportional Size: See and adjust the falloff radius. · Connected: The proportional falloff gets calculated for connected parts only. · Projected(2D): The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Push/Pull

It pushes or pulls the object positions relative to the center of the selection.

In Object mode this tool requires to have more than one object selected.

Adjust Last Operation - Push/Pull
Last Operator Push/Pull
EntryWhat it does
DistanceAdjust the strength of influence of the tool.
Mirror EditingEnables mirror editing.
Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Scale Feather

Scale Feather

Scale feather weight for the selected points.

The curve type that is used to create mask splines is almost a Bezier curve. But it has some differences. Smooth edges of the mask are defined by feathering. The curve needed to support feathering in a way that stuck to the curve as you edited it, for ease of editing an animation. These are called S-Curves.

Besides the handles, every control point also has points that define the feather between the current point and the next point on the spline. Each feather point is stored in UV space, where U means position across spline segment, and V means distance between main spline and feather points.

Adjust Last Operation - Transform
Last Operator Transform
EntryWhat it does
ValuesAdjust the scale amount. X, Y and Z defines the position. W defines the rotation.
AxisAround which axis to rotate. X, Y or Z.
Orientation
Orientation

Orientation is a drop-down box where you can choose the type of orientation for the transform action.

Mirror Editing

Enables mirror editing.

Proportional Editing
Proportional Editing

Proportional Editing is a drop-down box where you can choose to use proportional editing. When you choose one of the active methods then the neighbor geometry gets influenced too in a proportional way.

Proportional Editing Falloff

Proportional Editing Falloff

Proportional Editing Falloff is a drop-down box where you can choose a method for the falloff for the proportional editing.

EntryWhat it does
Proportional sizeProportional size is an edit box to adjust the strength of the Proportional falloff.
ConnectedJust edit geometry that is directly connected with the current selection. 4 Bforartists 2 Reference Manual - 7.1.4 Editors - 3D View - Header - Navigation Menu
Projected ( 2D)Edit geometry that is in 2d space aligned with the current selection. This one goes from the current view in depth direction.

Clear Feather Weight

Reset the feather weight to zero.

EntryWhat it does
DuplicateDuplicates the selected curve and moves it.
DeleteDeletes the selected mask curve point.
Copy SplinesCopies the currently selected spline.
Paste SplinesPastes a copied spline.
Make ParentSet the mask's parenting.
Clear ParentClears the mask's parenting.
Toggle CyclicMake the spline closed or open.
Switch DirectionSwitch the direction in which the spline points. A spline has a direction. A starting point and an endpoint. By switching the starting point becomes the end point, the end point becomes the starting point.
Recalc NormalsRecalculate the direction of the selected spline handlers.

Set Handle Type

Set Handle Type

In this sub menu you can set the handle type for the currently selected spline points.

Animation

Animation

Insert Shape Key

Insert Shape Key

Inserts a shape key keyframe.

The inserted keyframes can then be found in the dope sheet editor in mask mode.

Clear Shape Key

Clears an existing shape key keyframe.

Reset Feather Animation

Resets the feather offset across all animated frames.

Re-key Shape points

Recalculate animation data on selected points for frames selected in the dope sheet.

Show / Hide

Show / Hide
EntryWhat it does
Show HiddenReveals all hidden curves
Hide SelectedHides the selected curve.

Hide Unselected

Hides the unselected curves.

Adjust Last Operation - Hide Layer
Last operator Hide Layer
Last operator Hide Layer
Unselected

Hide selected or unselected curves.